How to check if program is ABAP 6.10 compliant?

In a unicode systems, programs should be an ABAP 6.10 compliant in order for it to run smoothly. To check your program, use the transaction UCCHECK.

Transaction SCOV is used to monitor the testing of program if it catches non-static errors during runtime.

How to get network interface info in AIX?

To find network interface card information in AIX, issue the commad:

# entstat -d <network interface id>

To find out the network interface id, issue the command:

# ifconfig -a

Few ways to find mac address of a network card:

# ifconfig -a (as root)

# lscfg -vl <network card id> (for AIX)

# netstat -v

# entstat <network card id> (for AIX)

Mac address is 12 hexadecimal digits (digits 0-9 letter a-f) in six
pairs of digits separated by colons ( example: 00:02:53:d5:c7:28 ).

How to check if ssh is installed in an AIX server?

Issue command: lslpp -l |grep ssh
myserver123:/home/admid123> lslpp -l |grep ssh
freeware.openssh.rte 3.7.1.0 COMMITTED OpenSSH 3.7p1

The command list the installed (applied/committed) filesets in the server.

SNOTE Tcode

The Note Assistant (transaction SNOTE) helps you when working with SAP Notes. You can use it to load SAP Notes into your system from the SAP Service Marketplace or SAPNet – R/3 Frontend.

After you have loaded the SAP Notes you need into your system, you can automatically implement the corrections (correction instructions) contained in the notes into your system.

In configuring SNOTE’s RFC connection, when it asks for authentication user & password, give user “OSS_RFC” password CPIC“.

Installing SAP Help/Library

Step1: Install SAP library on your local P.C.
Step 2: Configure the sapdoc.ini
Configure file sapdoc.ini with the entry as shown. This file exists on C:\Windows. If it is not found, create it using your favorite text editor.
—-
[HTMLHELP]
HelpType=HtmlHelpFile
HtmlHelpFilePath-EN=<C:\Program Files\SAP\SAP ERP Central Component 5.0 English\HELPDATA\EN> : Path of SAP help where you installed it on your P.C.
—-
Step3: logon to sap dev system
            – Execute the tcode SR13
            – Click on the tab HtmlHelp file
            – Click on New entries
            -Enter variant name (ECC5 if u r using SAP ECC5)
            -Platform =Win32 if you are using xp
            -Area =IWBHELP
            -Path = http://help.sap.com Or path of the your server where SAP library is installed.

             Save it. Request Dialog prompts you to create request. Create Request.

            Transport the request to Quality & Production.

Note: Entries in the file sapdoc.ini overwrites the settings present in SR13, if SAP library is not available on your local 
system, it starts from central location.

Profile parameters descriptions

rdisp/max_alt_modes – limits the number of SAP session users can open

Ways to increase maxextent value.

Without directly updating the oracle database via sql command an admin can use the following:

1. Using tcode SE14 – ABAP Diction : Database Utility, enter the table name and  follow the path:
    – edit->storage parameter->goto->for new creation->ok

2. Use the old SAP tool named sapdba or the new one named brtools.

Setting ORACLE DB into noarchivelog mode

Steps when the database state is down:
1. Login to sqlplus
  -sqlplus /nolog
  -connect / as sysdba

2. The db must be mounted EXCLUSIVE and not open for operation
  –startup mount;
3. Check the log mode status of the database
  –select log_mode from v$database;
4. Setting it to noarchivelog mode
  –alter database noarchivelog;
5. Setting db open for user operation
  –alter database open;
6. Reverting back to archivelog mode
  –alter database archivelog;

Creating SAP shortcut

To add the SAP shortcut item when you right-click your mouse, you have to run the file named sapshcut.exe. It is usually located in the directory where the SAP GUI is installed. You will notice that you are now able to create SAP shorcuts but the password field is grayed out. For your to add the password in the shortcut, you have to edit the windows registry by searching for “SAPShortcut”, the “Security” folder under it, edit the value of “EnablePassword” from 0 to 1.

Caveat: Storing passwords in the shortcuts is an audit violation.

How to lock the client only and not the entire system?

To lock or unlock a client only in an in R/3 System, run the following functions via tcode SE37:
1. SSCR_LOCK_CLIENT
2. SSCR_UNLOCK_CLIENT

Locking/unlocking the entire system, an admin can use the following commands:
1. tp locksys <SID> pf=<transport profile>
2. tp unlocksys <SID> pf=<transport profile>

    – transport profile in /usr/sap/trans/bin usually -> TP_DOMAIN_.PFL
– SAP* id will still be able to login.


Pages

My Favorites

SAP
May 2024
S M T W T F S
 1234
567891011
12131415161718
19202122232425
262728293031  

Previous Entries